Every time I try to play a video on my Nokia Lumia 810, the video stops working right and the audio becomes muffled. Also, the pause and play menu flashes off and on. I usually have to put my phone to sleep and turn it on again to continue playing the video. However, this process occurs multiple times. This happens on both my YouTube app and my internet explorer. I'm not sure what I can do to fix this.
by
retagged by

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register.

1 Answer

You can do one of 3 things. See if there any updates for you phone. You can take your phone to Tmobile. If one is near you,you can also take it to a Micro Soft store,or email them,and u can google the problem. One last thought,not trying to spend your money,but it just might be time to buy a new phone. You  can get good used or brand new Nokia 925 from either Ebay or

Amazon for $130-250.
by

Welcome to Tech Support Questions, where you can ask questions and receive answers from other members of the community.

Post questions regarding any technology problem including problems with phones and tablets, computers and laptops, windows and apple devices and more. Help other members of the community by answering questions.

Note: Please do not post private information such as passwords or usernames.

5,771 questions
2,926 answers
141 comments
28,016 users